Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DeSync Issues
2016-09-06, 02:07 PM
Post: #1
Exclamation DeSync Issues
A Mate and I just started playing together on MP, and after an update, we're experiencing desync to the extent that the game is now unplayable on mp. we've checked our internet connections and Voip didn't initially cause problems. Has anyone got a fix or having the same issues?
Find all posts by this user
Quote this message in a reply
2016-09-21, 05:33 AM (This post was last modified: 2016-09-21 07:31 PM by Falco.)
Post: #2
RE: DeSync Issues
(2016-09-06 02:07 PM)Gazzmask Wrote:  A Mate and I just started playing together on MP, and after an update, we're experiencing desync to the extent that the game is now unplayable on mp. we've checked our internet connections and Voip didn't initially cause problems. Has anyone got a fix or having the same issues?

Could you perhaps describe the issues in more detail?
I've had issues with multiple things such as
- vehicle position desync
- engine usage desync
- lua related desync (lua not controlling propulsion clientside)
- turret rotation desync
- ammo not loading into APS clips for clients but for host, both without any warning and with the warning that the shells are too long (without them being too long)
- the latency just counting up (F2 view) without resetting
- cram cannons not displaying they're reloaded and just counting up the reload time
- cram shells not displaying the correct damage values, both on the cannon and on the projectile cam
- subobjects being spawned clientside if placed by client, but then the host reporting they're not there. changing them clientside simply refuses to change anything
- blocks not spawning in right away needing the host to confirm their presence seriously slowing down building things in a line and such.
- an especially fun one was when I assigned weapon groups and it didn't update for the host. so for me the weapons turned but didn't shoot unless they were pointed the same way as the host's weapons.
- many more

It is indeed very unplayable.
Then again, the guy I'm playing with is on the other side of the world and his connection is quite bad. While problems are to be expected, they should be coped with as well as possible. Better slow netcode than broken netcode.
Things should be calculated hostside, and all updates should be sent to the clients. between updates clients use their information to calculate how things will be until the next update, but ultimately only the host should have authority over what's going on.

For instance: LUA code tells heliblade to spin at 22rad/s
Expected behavior:
- heliblade spins at 22rad/s for client and host
- client calculates estimated acceleration and position based on heliblade rotation given by host
- host calculates vehicle position changes (speed) how it would in singleplayer
- host updates the client on the actual vehicle position with every heartbeat, along with other updates regarding every object and subobject in the game.
Observed behavior:
- helibalde spins at 22rad/s for host only
- client calculates estimated acceleration and position change based on it's (0) heliblade rotation
- host calculates estimated acceleration and position change based on it's (22) heliblade rotation
- host does not update client on the actual position or the rotation speed of the blades.
- host does not update client on engine use by the blade
- host somehow does update the fuel usage though
Find all posts by this user
Quote this message in a reply
2016-09-27, 03:02 AM
Post: #3
RE: DeSync Issues
Secon... Thirded. Major desync issues here too:
Ship under friend's control disappears entirely, shells from it appear but nothing else.
Enemy ships are 50-100 meters away from where they appear to be based on their shots
Completely broken map (icons remain on screen after closing map, and do not update even if the map is re-opened)
We couldn't even get far enough in to test a lot of the things Falco mentions, its just completely unplayable.

"Yarp...Yarp......Narp?"
Find all posts by this user
Quote this message in a reply
2016-11-16, 10:18 AM
Post: #4
RE: DeSync Issues
I have this kind of desync are you using a PID controler anywhere on your vehicules ?
Find all posts by this user
Quote this message in a reply
2016-11-21, 10:54 AM (This post was last modified: 2016-11-21 11:01 AM by Softie.)
Post: #5
RE: DeSync Issues
I and a friend are having this issue two. The first design will load in, incoming uploads and design database fine. Then normally the second time will freeze before 100% under design database.


Edit ~ Friend left server and design loaded instantly (well when he left )

Edit 2 ~ Everytime we exit server or I try to with him still in it, game crashes.
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-11-22, 06:59 PM
Post: #6
RE: DeSync Issues
FtD, from what I understand, suffers from the issue that if someones internet 'hiccups', FtD will not attempt to re-issue the connection and instead drop it while keeping both players in the game. It can be seen when you go into F2 as already described and go to 'coms', if the latency just ticks up that means none of your packets are getting to the other player(s) and essentially communication has been lost.

The other above desync issues are common for me as well as many other people.

Owner of your F.riendly N.eighborhood fleet.
Builds stupid things, wins funny prizes.
Find all posts by this user
Quote this message in a reply
2017-03-18, 06:42 PM
Post: #7
RE: DeSync Issues
+1.
Bump...? (I mean seriously why is this forum so dead though?)

I'm pretty sure 90% of players experience this exact thing. Ever since a few updates ago FTD has had acquired absolute ZERO tolerance for packet-loss and will just crap-out randomly in the middle of a game.

Also, this is kind of unrelated but equally game-breaking, is anyone actually able to exit a multiplayer server to title without the game crashing for no Lamb reason?

[Image: wpidR4E.png]
Here's my profile in case want to check me out on steam workshop, or in case you specifically don't. Dodgy
[https://steamcommunity.com/id/coconut219]
Visit this user's website Find all posts by this user
Quote this message in a reply
2017-07-20, 06:50 PM
Post: #8
RE: DeSync Issues
any idea when this will be fixed?
Find all posts by this user
Quote this message in a reply
2017-08-05, 01:09 AM (This post was last modified: 2017-08-05 01:09 AM by BigNose.)
Post: #9
RE: DeSync Issues
I also agree, since 2.0 I have (and it was bad before that, but not AS bad) absolutely gamebreaking desync issues within the first minutes of normal play, just 2 vessels (starting fortress and starter boat) with a 2 person (host+client) COOP campaign. The issue described above I strongly assume happen to everyone, as this is clearly netcode related.

To be honest, the multiplayer right now feels in a state of disregard and should not be included until at least working on a basic level. The rest of the game, especially since 2.0, is polished enough to make the MP feel just out of place right now.

I plead for disabling it (and stop the influx of apparently known issues, that are just not cared for at this time), and only reintegrating MP once it's working on a basic level.
Find all posts by this user
Quote this message in a reply
2017-08-29, 10:25 AM
Post: #10
RE: DeSync Issues
I second the gamebreaking gameplay, me and my brother play within the same internal network, and in the past, the connection is thrown initially to the master server, then once FTD realises we are the same network, it swaps to lan mode, this means that we can discount the "internet connection" entirely, and see it for what it is.
the network code is currently busted, from basic player physics (join and get bounced upwards initially off the turret)
to placement glitches. it obviously is broken utterly.
i've personally got enough time to run to the starting rib, enter build mode on the turret, and add a few missile tubes before the game desyncs and we get told "player has left the game".

just saying it may need some help.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)