From The Depths - Forum
[1.96?] Torpedo-related NRE - Printable Version

+- From The Depths - Forum (http://www.fromthedepthsgame.com/forum)
+-- Forum: Alpha (/forumdisplay.php?fid=9)
+--- Forum: Bug reports (/forumdisplay.php?fid=10)
+--- Thread: [1.96?] Torpedo-related NRE (/showthread.php?tid=26393)



[1.96?] Torpedo-related NRE - Richard Dastardly - 2017-01-10 01:03 PM

Have no idea if this is repeatable, just noticed a horrid slowdown fighting a LH sub & checked the log to find endless spam of this ( did a search & found nothing, so I have no idea how old a bug it is )

Code:
NullReferenceException: Object reference not set to an instance of an object
  at MissilePropeller.Run () [0x00000] in <filename unknown>:0
  at CustomMissile.ServerFixedUpdate () [0x00000] in <filename unknown>:0
  at CustomMissile.FixedUpdate () [0x00000] in <filename unknown>:0

Kinda hard to know what the matter is from that tiny stack trace, but well, better than nothing.


RE: [1.96?] Torpedo-related NRE - ARCAGNELL0 - 2017-01-10 02:25 PM

I've also noticed it. I think it's not the torpedo's fault but the vehicle you're fighting against.

I've had this issue with the Hydrovolt or as I like to call it, the Sploitvolt 9000.

It jitters so hard in combat due to the rudder stacks that torpedoes with guidances (TPG) start lagging a lot due to continuous course changes.


RE: [1.96?] Torpedo-related NRE - Richard Dastardly - 2017-01-12 04:49 PM

Yeah it's definitely initiated by the Hydrovolt - but it's still something that shouldn't happen.